Author Topic: Troubleshooting Known Issues for Shadows of Amn and Throne of Bhaal  (Read 82776 times)

0 Members and 1 Guest are viewing this topic.

Offline Solaufein

  • Lord of the Realms
  • Administrator
  • Level 5
  • *****
  • Posts: 5164
  • Karma: +127/-19
  • Gender: Male
  • The night is dark and full of terrors...
    • ICQ Messenger - 251194643
    • Yahoo Instant Messenger - gscott7833
    • View Profile
Re: Troubleshooting Known Issues for Shadows of Amn and Throne of Bhaal
« Reply #30 on: May 19, 2013, 02:59:34 PM »
Mouse/keyboard problems (eg. Non-responding interface)

Uninstall the software that came with the cordless keyboard/mouse. You do not need that buggy software. Let Windows autodetect them and then they work fine. I'm using a Logitech cordless keyboard and a cordless Logitech mouse. I never ever installed the files that I was supposed to need for them. Windows simply detects them and loads the needed files.

Wireless keyboards/mice

Posted: Monday, 23 June 2003 10:42PM
I felt the time was right to install BG again and play it all through. After started a new game, i immediately notice i cant click the special ability button (F12 hotkey too). It makes a click sound and nothing happens. Also, when i click detect traps or bard song, it says "detecting traps" then immediately "stopped detecting traps".....therefore i cannot use this ability, or use the attack/bardsong/magic/talk etc. buttons. Even the hotkeys dont work!

Please can someone help me, the game is totally unplayable like this!

im running windows XP on an athlon xp 2200+, 256 mb RAM, 80 gb hard disk..urrrm, geforce 4 mx 440 with directX 9....

ive tried reinstalling but to no avail. Plz someone help!

Monday, 23 June 2003 11:56PM
Sounds like you might have a wireless keyboard/mouse. If that's the case, you can try these things: disable hotkeys on your keyboard; disable keyboard/mouse software on your computer; play with a USB or PS2 connected keyboard/mouse. Those are the only known solutions to date.

Monday, 28 July 2003 10:35AM
I had the same problem, except I didn't read this thread, so I posted the info to another thread. Anyways, my solution was to uninstall the keyboard monitoring software as I don't really need it. The mouse monitoring software is still installed so that should be fine. And I'm still using the keyboard and mouse on the PS/2 ports as usual. It seems the problem is related to the software itself.

Here are the symptoms:

1) When you are on the main game menu, you can't seem to use your thieving, special abilities, cast spells, etc. You CAN use items and equip different weapons and group attack and stop, but anything that requires being in a different state doesn't seem to work.

2) When you put something in one of the item slots, they get used up or constantly in use like someone was pressing the keyboard shortcut a lot (F9 in my case)

3) When you try to switch formations, it keeps sending you to the same formation which you do NOT choose.

4) You can cast spells or use special abilities by going to some other screen and then quickly pressing one of the buttons.


The problem seems to be with the wireless keyboard monitoring software. It seems to be passing extra keypresses to the game.


Disable or uninstall the wireless keyboard monitoring software (At least this worked for me). Others seemed to have success by moving the wireless connection to a different USB or PS/2 port?

Anyways the software that I was having problems with was the iTouch keyboard software that came with the Logitech Navigator Duo Wireless Keyboard/Mouse combo. Not sure if this is the same software that the user above had, but it seems a safe bet that if you have this software, you will get behavior like what I described above.

Thanks to Kevin Lynch for pointing me to this thread, though I would suggest a different title. I think my problem was I read it as ("Strange ability button" problem) as if you get an extra strange ability in the game rather than Strange "ability button" problem.
« Last Edit: May 19, 2013, 03:03:53 PM by Solaufein »
My mods:
Dark Horizons
The Undying
IWD2 store

Dark Side of the Sword Coast BG1 Weidu
Aurils Bane
Baldur's Gate - Enhanced Edition beta tester
Baldur's Gate 2 - Enhanced Edition beta tester
Icewind Dale - Enhanced Edition beta tester